const regex = new RegExp('(^.+[^/f/])', 'gm')
const str = `/televizory-i-cifrovoe-tv/televizory-65?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/category=4k-uhd-televizory-1682?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/category=led-8k-televizory-6947?reff=menu_main
/televizory-i-cifrovoe-tv-1/televizory-65/f/smart-tv=da?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/kvantovij_tochki_tv=da?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/category=oled-televizory-1987?reff=menu_main
/televizory-i-cifrovoe-tv-1/televizory-65/f/collection_bottom=seriya-frame?reff=menu_main`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}