re = /(^.+[^\/f\/])/m
str = '/televizory-i-cifrovoe-tv/televizory-65?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/category=4k-uhd-televizory-1682?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/category=led-8k-televizory-6947?reff=menu_main
/televizory-i-cifrovoe-tv-1/televizory-65/f/smart-tv=da?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/kvantovij_tochki_tv=da?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/category=oled-televizory-1987?reff=menu_main
/televizory-i-cifrovoe-tv-1/televizory-65/f/collection_bottom=seriya-frame?reff=menu_main'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end