// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^.+[^/f/])").unwrap();
let string = "/televizory-i-cifrovoe-tv/televizory-65?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/category=4k-uhd-televizory-1682?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/category=led-8k-televizory-6947?reff=menu_main
/televizory-i-cifrovoe-tv-1/televizory-65/f/smart-tv=da?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/kvantovij_tochki_tv=da?reff=menu_main
/televizory-i-cifrovoe-tv/televizory-65/f/category=oled-televizory-1987?reff=menu_main
/televizory-i-cifrovoe-tv-1/televizory-65/f/collection_bottom=seriya-frame?reff=menu_main";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}