#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([?&])ordem=\d+(?:&|$)"
Local $sString = "http://www.meudominio.com.br/pagina.php?campo=teste&cor=azul&ordem=2" & @CRLF & _
"http://www.meudominio.com.br/pagina.php?campo=teste&ordem=2&cor=azul" & @CRLF & _
"http://www.meudominio.com.br/pagina.php?ordem=2&campo=teste&cor=azul"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)