# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[?&]ordem=\d+//gm;t' <<< "http://www.meudominio.com.br/pagina.php?campo=teste&cor=azul&ordem=2
http://www.meudominio.com.br/pagina.php?campo=teste&ordem=2&cor=azul
http://www.meudominio.com.br/pagina.php?ordem=2&campo=teste&cor=azul"