package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[?&]ordem=\d+`)
var str = `http://www.meudominio.com.br/pagina.php?campo=teste&cor=azul&ordem=2
http://www.meudominio.com.br/pagina.php?campo=teste&ordem=2&cor=azul
http://www.meudominio.com.br/pagina.php?ordem=2&campo=teste&cor=azul`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}