import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[?&]ordem=\\d+";
final String string = "http://www.meudominio.com.br/pagina.php?campo=teste&cor=azul&ordem=2\n"
+ "http://www.meudominio.com.br/pagina.php?campo=teste&ordem=2&cor=azul\n"
+ "http://www.meudominio.com.br/pagina.php?ordem=2&campo=teste&cor=azul";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}