use strict;
my $str = 'http://www.meudominio.com.br/pagina.php?campo=teste&cor=azul&ordem=2
http://www.meudominio.com.br/pagina.php?campo=teste&ordem=2&cor=azul
http://www.meudominio.com.br/pagina.php?ordem=2&campo=teste&cor=azul';
my $regex = qr/[?&]ordem=\d+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";