# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[?&]ordem=\d+"
test_str = ("http://www.meudominio.com.br/pagina.php?campo=teste&cor=azul&ordem=2\n"
"http://www.meudominio.com.br/pagina.php?campo=teste&ordem=2&cor=azul\n"
"http://www.meudominio.com.br/pagina.php?ordem=2&campo=teste&cor=azul")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.