const regex = new RegExp('(Nokian|BFGoodrich|Pirelli|Toyo|Continental|Hankook|Mitas)\\s+(.*?)\\s+(\\d+)/(\\d+)\\s*([a-z]+)(\\d+)C?\\s+([\\/\\d]+)([a-z]+)\\s*([a-z]+)?\\s*(RunFlat|Run Flat|ROF|ZP|SSR|ZPS|HRS|RFT)?\\s*.*?\\s*(TT|TL|TL/TT)', 'iu')
const str = `Toyo H08 195/75R16C 107/105S TL Летние`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}