use strict;
my $str = 'Toyo H08 195/75R16C 107/105S TL Летние';
my $regex = qr~(Nokian|BFGoodrich|Pirelli|Toyo|Continental|Hankook|Mitas)\s+(.*?)\s+(\d+)/(\d+)\s*([a-z]+)(\d+)C?\s+([\/\d]+)([a-z]+)\s*([a-z]+)?\s*(RunFlat|Run Flat|ROF|ZP|SSR|ZPS|HRS|RFT)?\s*.*?\s*(TT|TL|TL/TT)~iup;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}