// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?iu)(Nokian|BFGoodrich|Pirelli|Toyo|Continental|Hankook|Mitas)\s+(.*?)\s+(\d+)/(\d+)\s*([a-z]+)(\d+)C?\s+([\/\d]+)([a-z]+)\s*([a-z]+)?\s*(RunFlat|Run Flat|ROF|ZP|SSR|ZPS|HRS|RFT)?\s*.*?\s*(TT|TL|TL/TT)").unwrap();
let string = "Toyo H08 195/75R16C 107/105S TL Летние";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}