// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*) +([0-9,]+) +([\w]+)").unwrap();
let string = "This ingredient 0,5 g
This extra ingredient 11,7 cups
- od tega laktoza 3,6 g";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}