const regex = /(.*?)\?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)\\?', 'gm')
const str = `https://www.pap.fr/annonces/appartement-paris-18e-75018-r430701902?a=17172977&email=marcjagu%40gmail.com&md5=661499763cc85bc35eac029437fb2057&utm_source=alerte_vente&utm_medium=email&utm_campaign=alerte_vente`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}