re = /(.*?)\?/m
str = 'https://www.pap.fr/annonces/appartement-paris-18e-75018-r430701902?a=17172977&email=marcjagu%40gmail.com&md5=661499763cc85bc35eac029437fb2057&utm_source=alerte_vente&utm_medium=email&utm_campaign=alerte_vente'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end