// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*?)\?").unwrap();
let string = "https://www.pap.fr/annonces/appartement-paris-18e-75018-r430701902?a=17172977&email=marcjagu%40gmail.com&md5=661499763cc85bc35eac029437fb2057&utm_source=alerte_vente&utm_medium=email&utm_campaign=alerte_vente";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}