#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<(\w+)[^<>]*?>(.*?)<\/\1>"
Local $sString = "<div><span>text text</span></div><a href="#">link</a>" & @CRLF & _
"<div><input type="button" value="click"><ul><li>item1</li><li>item2</li></ul></div>" & @CRLF & _
"<p><pos w="12">good</pos></p>" & @CRLF & _
"text<a href="#">text link</a>" & @CRLF & _
"<button>name</button><textarea></textarea>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")