using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<((?:Student)?ID)>(\d+)</\1>";
string input = @"<StudentID>12345</StudentID>
Or it can be
<ID>12345</ID>
The input can be
<Somedata>SSS<Somedata><StudentID>12345</StudentID><Name>MMM</Name>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}