const regex = /Name: (?<name>[^\n]+)[\n\r]+Email: (?<email>[^\n]+)[\n\r]+Phone: (?<phone>[^\n]+)[\n\r]+Business: (?<business>[^\n]+)[\n\r]+Message: (?<message>[^\n]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Name: (?<name>[^\\n]+)[\\n\\r]+Email: (?<email>[^\\n]+)[\\n\\r]+Phone: (?<phone>[^\\n]+)[\\n\\r]+Business: (?<business>[^\\n]+)[\\n\\r]+Message: (?<message>[^\\n]+)', 'gm')
const str = ` <link rel="canonical" href="https://autojapan.com.ua/zapchastyna-219-KITAJ-KD312615XA/" />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}