using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[*?_A-Za-z0-9]|\\[\\!""#$%&'()+,.\/:;<>=@[\]^`{|}~*?-])(?:[A-Za-z0-9_]|\\[\\!""#$%&'()+,.\/:;<>=@[\]^`{|}~*?-])*(?:\*|\?+)?";
string input = @"foo\-bar
Acrobat_Reader
\""oh_my\!\""
g\+\+
9\.?
sr*
big\$money
foo\:bar
back\\slash_software
with_quoted_\~tilde
*SOFT*
8\.??
*8\.??
?hello?
\\help1??
hello?hello";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}