#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<File>\s+now/best\s+size/ext\s+(\S+)\s+(\d+|\-)/(\d+|\-)\s+\-\s+Done\."
Local $sString = "<File> now/best size/ext" & @CRLF & _
".abc 5/5 -" & @CRLF & _
"Done." & @CRLF & _
"" & @CRLF & _
"<File> now/best size/ext" & @CRLF & _
".def 5/5 50m" & @CRLF & _
"Done." & @CRLF & _
"" & @CRLF & _
"<File> now/best size/ext" & @CRLF & _
".ghi 5/5 -" & @CRLF & _
"Done." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")