use strict;
my $str = '<File> now/best size/ext
.abc 5/5 -
Done.
<File> now/best size/ext
.def 5/5 50m
Done.
<File> now/best size/ext
.ghi 5/5 -
Done.
';
my $regex = qr/<File>\s+now/best\s+size/ext\s+(\S+)\s+(\d+|\-)/(\d+|\-)\s+\-\s+Done\./mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}