import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?=\\d*[a-z])(?=[a-z]*\\d)(?:[a-z]|(\\d)(?!\\w*\\1))+\\b";
final String string = "I would like abc123 to match but not 123.\n"
+ "ab12s should also match\n"
+ "Only number-words like 1234 should not match\n"
+ "Words containing same numbers like ab22s should not match\n"
+ "234 should not match\n"
+ "hel1lo2haha3hoho4\n"
+ "hel1lo2haha3hoho3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}