#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)fbq\('track'(?!.*?PageView)[^)]*\);"
Local $sString = "fbq('track', 'PageView');" & @CRLF & _
"" & @CRLF & _
" fbq('track', 'PageView');" & @CRLF & _
"" & @CRLF & _
"fbq('track', 'Purchase');" & @CRLF & _
"" & @CRLF & _
"fbq('track', 'Purchase'," & @CRLF & _
" // begin parameter object data" & @CRLF & _
" {" & @CRLF & _
" value: 115.00," & @CRLF & _
" currency: 'USD'," & @CRLF & _
" contents: [" & @CRLF & _
" {" & @CRLF & _
" id: '301'," & @CRLF & _
" quantity: 1" & @CRLF & _
" }," & @CRLF & _
" content_type: 'product'" & @CRLF & _
" }" & @CRLF & _
" // end parameter object data" & @CRLF & _
");" & @CRLF & _
"" & @CRLF & _
"fbq('track', 'PageView'," & @CRLF & _
" // begin parameter object data" & @CRLF & _
" {" & @CRLF & _
" value: 115.00," & @CRLF & _
" currency: 'USD'," & @CRLF & _
" content_type: 'product'" & @CRLF & _
" }" & @CRLF & _
" // end parameter object data" & @CRLF & _
");"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")