using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"fbq\('track'(?!.*?PageView)[^)]*\);";
string input = @"fbq('track', 'PageView');
fbq('track', 'PageView');
fbq('track', 'Purchase');
fbq('track', 'Purchase',
// begin parameter object data
{
value: 115.00,
currency: 'USD',
contents: [
{
id: '301',
quantity: 1
},
content_type: 'product'
}
// end parameter object data
);
fbq('track', 'PageView',
// begin parameter object data
{
value: 115.00,
currency: 'USD',
content_type: 'product'
}
// end parameter object data
);";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}