import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "fbq\\('track'(?!.*?PageView)[^)]*\\);";
final String string = "fbq('track', 'PageView');\n\n"
+ " fbq('track', 'PageView');\n\n"
+ "fbq('track', 'Purchase');\n\n"
+ "fbq('track', 'Purchase',\n"
+ " // begin parameter object data\n"
+ " {\n"
+ " value: 115.00,\n"
+ " currency: 'USD',\n"
+ " contents: [\n"
+ " {\n"
+ " id: '301',\n"
+ " quantity: 1\n"
+ " },\n"
+ " content_type: 'product'\n"
+ " }\n"
+ " // end parameter object data\n"
+ ");\n\n"
+ "fbq('track', 'PageView',\n"
+ " // begin parameter object data\n"
+ " {\n"
+ " value: 115.00,\n"
+ " currency: 'USD',\n"
+ " content_type: 'product'\n"
+ " }\n"
+ " // end parameter object data\n"
+ ");";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}