# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"fbq\('track'(?!.*?PageView)[^)]*\);"
test_str = ("fbq('track', 'PageView');\n\n"
" fbq('track', 'PageView');\n\n"
"fbq('track', 'Purchase');\n\n"
"fbq('track', 'Purchase',\n"
" // begin parameter object data\n"
" {\n"
" value: 115.00,\n"
" currency: 'USD',\n"
" contents: [\n"
" {\n"
" id: '301',\n"
" quantity: 1\n"
" },\n"
" content_type: 'product'\n"
" }\n"
" // end parameter object data\n"
");\n\n"
"fbq('track', 'PageView',\n"
" // begin parameter object data\n"
" {\n"
" value: 115.00,\n"
" currency: 'USD',\n"
" content_type: 'product'\n"
" }\n"
" // end parameter object data\n"
");")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.