import Foundation
let pattern = #"fbq\('track'(?!.*?PageView)[^)]*\);"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
fbq('track', 'PageView');
fbq('track', 'PageView');
fbq('track', 'Purchase');
fbq('track', 'Purchase',
// begin parameter object data
{
value: 115.00,
currency: 'USD',
contents: [
{
id: '301',
quantity: 1
},
content_type: 'product'
}
// end parameter object data
);
fbq('track', 'PageView',
// begin parameter object data
{
value: 115.00,
currency: 'USD',
content_type: 'product'
}
// end parameter object data
);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)