#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]\d{4}(-[a-zA-Z0-9]{2})?$"
Local $sString = "# The CMS, who maintain these codes, describe the format as:-" & @CRLF & _
"# "HCPCS Level II codes (also known as alpha-numeric codes) consist of a single alphabetical letter followed by 4 numeric digits."" & @CRLF & _
"# (https://www.cms.gov/medicare/coding-billing/healthcare-common-procedure-system)" & @CRLF & _
"# NOTE: This regex will not identify HCPCS Level I codes (AKA CPT codes)" & @CRLF & _
"# Also, some sources say the single letter ranges only from A-V (this regex follows A-Z)" & @CRLF & _
"# It's not clear if the first letter must be capitalized. This regex assumes not." & @CRLF & _
"# This version of the regex matches optional modifiers (ie a hyphen then 2 characters after the code)" & @CRLF & _
"# (https://www.aapc.com/resources/what-are-medical-coding-modifiers)" & @CRLF & _
"# A separate regex has been created on regex101 that ignores modifiers" & @CRLF & _
"" & @CRLF & _
"# Genuine code patterns" & @CRLF & _
"E8015" & @CRLF & _
"A6410" & @CRLF & _
"C5278" & @CRLF & _
"G2102" & @CRLF & _
"M1221" & @CRLF & _
"V2623" & @CRLF & _
"V2756" & @CRLF & _
"c5278" & @CRLF & _
"g2102" & @CRLF & _
"m1221" & @CRLF & _
"v2623" & @CRLF & _
"v2756" & @CRLF & _
"G2102-23" & @CRLF & _
"E8015-OK" & @CRLF & _
"V2756-L5" & @CRLF & _
"V2756-5Q" & @CRLF & _
"" & @CRLF & _
"# Should fail" & @CRLF & _
"EE8015" & @CRLF & _
"6410" & @CRLF & _
"E641O" & @CRLF & _
"[6410" & @CRLF & _
"_6510" & @CRLF & _
"g212" & @CRLF & _
"C52789" & @CRLF & _
"G2101-" & @CRLF & _
"G2101-2" & @CRLF & _
"G2101-K" & @CRLF & _
"G2101-OKK" & @CRLF & _
"G2101-123" & @CRLF & _
"G2101-!!" & @CRLF & _
"G2101-!1" & @CRLF & _
"G2101-()"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")