re = /^14:00\b[^]]*XXCODE[^]]*error[^]]*]/m
str = '14:00:01 | some text XXCODE <some text>
some text
]
14:00:02 | some text <some text> XXCODE error
sometext
]
14:00:03 | some text XXCODE <some text>
some text
and more text 412432
]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end