#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?mx) # x- modifiers to add comments in regex" & @CRLF & _
"#. #any character, except newline" & @CRLF & _
"#\s. #only space and newline characters" & @CRLF & _
"#\w+ #Word quantifiers to match 1 or more words" & @CRLF & _
"[\ \.\-]"
Local $sString = "123.345" & @CRLF & _
"123 345" & @CRLF & _
"123-456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")