import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?mx) # x- modifiers to add comments in regex\n"
+ "#. #any character, except newline\n"
+ "#\\s. #only space and newline characters\n"
+ "#\\w+ #Word quantifiers to match 1 or more words\n"
+ "[\\ \\.\\-]";
final String string = "123.345\n"
+ "123 345\n"
+ "123-456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}