$re = '/(?mx) # x- modifiers to add comments in regex
#. #any character, except newline
#\s. #only space and newline characters
#\w+ #Word quantifiers to match 1 or more words
[\ \.\-]/m';
$str = '123.345
123 345
123-456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);