package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)REGISTER sip:(?<your_field>(.|\n)+)User-Agent:`)
var str = `03:25:17.296: SIPTR: Received [0,UDP] 543 bytes from 10.xx.7x.1xx:8080 <<<<<
REGISTER sip:10.xx.7x.1xx SIP/2.0
Via: SIP/2.0/UDP 10.xx.7x.1xx;branch=hkhi8u09uj
From: "Dummy" ;tag=78979uh
CSeq: 68789 REGISTER
Call-ID: xxxxxx-7689-xxxx@10.xx.7x.1xx
Contact: ;methods="INVITE, ACK, BYE, CANCEL, OPTIONS, UPDATE, REFER"
User-Agent: Polycom_r64786r9879r87
Accept-Language: en
Max-Forwards: 70
Expires: 60`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}