#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^@id *= *1[\r\n]+((?:[^#]*#)+?)(?<=^#)$"
Local $sString = "alskdfkldsfjd" & @CRLF & _
"# thekt nect" & @CRLF & _
"@id=2" & @CRLF & _
"akdfjdkf" & @CRLF & _
"adlksfj" & @CRLF & _
"@id=1" & @CRLF & _
"adksfklasdjf // This line should be captured" & @CRLF & _
"asdlkfjdkfj // And this one" & @CRLF & _
"@id=3 // this one" & @CRLF & _
"dkfjadklfja // And #" & @CRLF & _
"#" & @CRLF & _
"kdsalfjaslkdf" & @CRLF & _
"#"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")