import re
regex = re.compile(r"^@id *= *1[\r\n]+((?:[^#]*#)+?)(?<=^#)$", flags=re.MULTILINE | re.DOTALL)
test_str = ("alskdfkldsfjd\n"
"# thekt nect\n"
"@id=2\n"
"akdfjdkf\n"
"adlksfj\n"
"@id=1\n"
"adksfklasdjf // This line should be captured\n"
"asdlkfjdkfj // And this one\n"
"@id=3 // this one\n"
"dkfjadklfja // And #\n"
"#\n"
"kdsalfjaslkdf\n"
"#")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")