import Foundation
let pattern = ##"^@id *= *1[\r\n]+((?:[^#]*#)+?)(?<=^#)$"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = ##"""
alskdfkldsfjd
# thekt nect
@id=2
akdfjdkf
adlksfj
@id=1
adksfklasdjf // This line should be captured
asdlkfjdkfj // And this one
@id=3 // this one
dkfjadklfja // And #
#
kdsalfjaslkdf
#
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)