#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[a-z]([a-z]+\d*|\d{2,})$"
Local $sString = "Paul46" & @CRLF & _
"4frank" & @CRLF & _
"mike" & @CRLF & _
"jus6tin" & @CRLF & _
"p87" & @CRLF & _
"k9" & @CRLF & _
"AL10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")