$re = '`(\/[a-z]+)?(?:\.htm)?`m';
$str = '/aaa/bbbb/ccccc.htm
/xxx/yyy.htm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);