package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^01[3-9]\d{8}$`)
var str = `7777777778
90332433443
01552377459
01203345454
01307728289`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}