$re = '/(\A.*staging\.(inlocoads|inlocomedia)\.com\z)|(\A.*localhost.*\z)/m';
$str = 'staging.inlocoads.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);