$re = '/([\w-]+)(\..*)?$/m';
$str = '../dir1/dir2/dir3/filename1.tar.gz
../dir1/dir2/dir3/filename2.tar
../dir1/dir2/dir3/filename3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);