#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<[^<>&]+>(*SKIP)(*FAIL)|[<>&]+"
Local $sString = "<b>bold</b>, <strong>bold</strong>" & @CRLF & _
"<i>italic</i>, <em>italic</em>" & @CRLF & _
"<a href="http://www.example.com/" >inline URL</a>" & @CRLF & _
"<code>inline fixed-width code</code>" & @CRLF & _
"<pre>pre-formatted fixed-width code block</pre>" & @CRLF & _
"yes<b bad<>b> <bad& hi>;<strong >b<a<"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")