using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^<>&]+>(*SKIP)(*FAIL)|[<>&]+";
string input = @"<b>bold</b>, <strong>bold</strong>
<i>italic</i>, <em>italic</em>
<a href=""http://www.example.com/"" >inline URL</a>
<code>inline fixed-width code</code>
<pre>pre-formatted fixed-width code block</pre>
yes<b bad<>b> <bad& hi>;<strong >b<a<";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}