# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\'"])(.*?)\1|i/\1&/g;t' <<< "\"word1 word2\" \"word3 word4\" word5 word6"