const regex = /([\'"])(.*?)\1|i/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\\'"])(.*?)\\1|i', 'g')
const str = `"word1 word2" "word3 word4" word5 word6`;
const subst = `\1&`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);