import re
regex = re.compile(r".*<!\[CDATA\[00000:((?:.|\r?\n)*?)\]\]>.*")
test_str = ("String srcMsg=\"<?xml version=\\\"1.0\\\" encoding=\\\"UTF-8\\\"?>\\n<root><resultCode>00000</resultCode><resultDesc>\n"
"<![CDATA[00000:<ResponseClass Name=\\\"Response\\\">\\n <ResponseSubClass Name=\\\"attributesResponse\\\">\\n\n"
" <ITEM>0</ITEM>\\n </ResponseSubClass>\\n</ResponseClass>]]></resultDesc></root>\";\n"
"//The right code \n"
"java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(\".*<!\\\\[CDATA\\\\[00000:((.|\\n)*)\\\\]\\\\]>.*\"); \n"
"//wrong code1 \n"
"//java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(\".*<!\\\\[CDATA\\\\[00000:(\\\\s|\\\\S)*\\\\]\\\\]>.*\");\n"
"//wrong code2 \n"
"//java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(\".*<!\\\\[CDATA\\\\[00000:[\\\\w|\\\\W]*\\\\]\\\\]>.*\");\n"
"java\n\n\n"
"<![CDATA[00000: asdfasdf\n"
"sssdgasgf\n\n"
"asfgas\n"
"]]>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")