package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9]+_[a-zA-Z0-9]+_[a-zA-Z0-9]+$`)
var str = `SOM_P9ERR96M27VP4_PL
SOM__P9QTR96M27VP4PL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}