// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z0-9]+_[a-zA-Z0-9]+_[a-zA-Z0-9]+$").unwrap();
let string = "SOM_P9ERR96M27VP4_PL
SOM__P9QTR96M27VP4PL";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}