# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^https?:\\/\\/(?:www\.)?(.{25}(?:(?<=\w)\w*|\b)).{5,}$/$1/s;t' <<< "https://forum.textpattern.com/viewtopic.php?pid=338199#p338199"